re = /^\[?(\w+,)*(abc|def)(,\w+)*]?=/m
str = '%% good examples
x=1
aabc=1
abc=1
[other,abc]=deal(1,2)
%% bad examples
[x,aabcc]=deal(1,2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end