import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[?(\\w+,)*(abc|def)(,\\w+)*]?=";
final String string = "%% good examples\n"
+ "x=1\n"
+ "aabc=1\n"
+ "abc=1\n"
+ "[other,abc]=deal(1,2)\n\n"
+ "%% bad examples\n"
+ "[x,aabcc]=deal(1,2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}