#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\{(.[^,\n\]]*)\}\s*(\((\d*)\))?"
Local $sString = "{item1}, {item2} (2), {item3} (4), {item4}" & @CRLF & _
" (1), {item5},{item6}(5)"
Local $sSubst = "{\"name\":\"${1}\", \"count\":\"$3\"}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)