$re = '/\{(.[^,\n\]]*)\}\s*(\((\d*)\))?/';
$str = '{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5},{item6}(5)';
$subst = "{\"name\":\"${1}\", \"count\":\"$3\"}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;