import re
regex = re.compile(r"\{(.[^,\n\]]*)\}\s*(\((\d*)\))?")
test_str = ("{item1}, {item2} (2), {item3} (4), {item4}\n"
" (1), {item5},{item6}(5)")
subst = "{\\\"name\\\":\\\"${1}\\\", \\\"count\\\":\\\"$3\\\"}"
result = regex.sub(subst, test_str)
if result:
print(result)