using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(.[^,\n\]]*)\}\s*(\((\d*)\))?";
string substitution = @"{\""name\"":\""${1}\"", \""count\"":\""$3\""}";
string input = @"{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5},{item6}(5)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}