const regex = /\{(.[^,\n\]]*)\}\s*(\((\d*)\))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(.[^,\\n\\]]*)\\}\\s*(\\((\\d*)\\))?', 'g')
const str = `{item1}, {item2} (2), {item3} (4), {item4}
(1), {item5},{item6}(5)`;
const subst = `{\"name\":\"${1}\", \"count\":\"$3\"}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);