import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(.[^,\\n\\]]*)\\}\\s*(\\((\\d*)\\))?";
final String string = "{item1}, {item2} (2), {item3} (4), {item4}\n"
+ " (1), {item5},{item6}(5)";
final String subst = "{\\\"name\\\":\\\"${1}\\\", \\\"count\\\":\\\"$3\\\"}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}