using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$";
string input = @":aaa 001 haaaa heu hii hoooo huuu
:aa NICK allo pateee :hello jhsdfhu
NOTICE :allo, les potes comment va ?
AAA a b c d e f :allo, ok !&*8? -_=% :okok";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}