const regex = /^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$', 'gm')
const str = `:aaa 001 haaaa heu hii hoooo huuu
:aa NICK allo pateee :hello jhsdfhu
NOTICE :allo, les potes comment va ?
AAA a b c d e f :allo, ok !&*8? -_=% :okok`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}