re = /^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$/m
str = ':aaa 001 haaaa heu hii hoooo huuu
:aa NICK allo pateee :hello jhsdfhu
NOTICE :allo, les potes comment va ?
AAA a b c d e f :allo, ok !&*8? -_=% :okok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end