import re
regex = re.compile(r"^(?:(:[a-zA-Z0-9.-]+) )?([a-zA-Z]+|[0-9]+)((?: [a-zA-Z0-9]+)*(?: :.+)?)$", flags=re.MULTILINE)
test_str = (":aaa 001 haaaa heu hii hoooo huuu\n"
":aa NICK allo pateee :hello jhsdfhu\n"
"NOTICE :allo, les potes comment va ?\n"
"AAA a b c d e f :allo, ok !&*8? -_=% :okok")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")