using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<group_definition>
\(
(?P<options>[^\:\>\s\(\)]*[\:\>])?
(?P<pattern>
(?:[^\)\(]*(?R)*)*
)
\)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)";
string input = @"^(?P<line>(?P<junk>(?!(?:Message\-ID:)\s(?:\<)|(?:<)|(?:\s))(?!(?:From:)\s(?:\<)|(?:<)|(?:")|(?:[""]))(?!(?:To:)\s(?:\<)|(?:<)|(?:")|(?:[""]))(?!(?:Reply\-To:)\s(?:\<)|(?:<)|(?:")|(?:[""]))(?!(?:X\-Sender:)\s(?:\<)|(?:<)|(?:")|(?:[""]))(?!(?:Return\-Path:)\s(?:\<)|(?:<)|(?:")|(?:[""]))(?!(?:Received\-SPF:))[^\r\n]*)(?P<wtf>(?:(?:\""(?P<display_name>[^\""\r\n]*)\""\s*)?\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\.)*)?(?P<sld>[A-Z0-9.-]+)\.(?P<tld>[A-Z]{2,4})))\b)\h*)(?P<trailing_data>[^\r\n]*))$
(this is a group)?
(another group (with a group inside)) and soem bogus test (and then another group)
(?P<group_definition>
(?P<pattern>
\(
(?:[^\)\(]*(?R)*)*
\)
)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}