const regex = /(?P<group_definition>
\(
(?P<options>[^\:\>\s\(\)]*[\:\>])?
(?P<pattern>
(?:[^\)\(]*(?R)*)*
)
\)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<group_definition>
\\(
(?P<options>[^\\:\\>\\s\\(\\)]*[\\:\\>])?
(?P<pattern>
(?:[^\\)\\(]*(?R)*)*
)
\\)
(?P<quantifier>
(?:[\\*\\+\\?])|
(?:
\\{(?P<min>\\d*)
(?:
,
(?P<max>\\d*)?
)?
\\}
)
)?
)', 'img')
const str = `^(?P<line>(?P<junk>(?!(?:Message\\-ID:)\\s(?:\\<)|(?:<)|(?:\\s))(?!(?:From:)\\s(?:\\<)|(?:<)|(?:")|(?:["]))(?!(?:To:)\\s(?:\\<)|(?:<)|(?:")|(?:["]))(?!(?:Reply\\-To:)\\s(?:\\<)|(?:<)|(?:")|(?:["]))(?!(?:X\\-Sender:)\\s(?:\\<)|(?:<)|(?:")|(?:["]))(?!(?:Return\\-Path:)\\s(?:\\<)|(?:<)|(?:")|(?:["]))(?!(?:Received\\-SPF:))[^\\r\\n]*)(?P<wtf>(?:(?:\\"(?P<display_name>[^\\"\\r\\n]*)\\"\\s*)?\\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\\.)*)?(?P<sld>[A-Z0-9.-]+)\\.(?P<tld>[A-Z]{2,4})))\\b)\\h*)(?P<trailing_data>[^\\r\\n]*))\$
(this is a group)?
(another group (with a group inside)) and soem bogus test (and then another group)
(?P<group_definition>
(?P<pattern>
\\(
(?:[^\\)\\(]*(?R)*)*
\\)
)
(?P<quantifier>
(?:[\\*\\+\\?])|
(?:
\\{(?P<min>\\d*)
(?:
,
(?P<max>\\d*)?
)?
\\}
)
)?
)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}