import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<group_definition>\n"
+ " \\(\n"
+ " (?P<options>[^\\:\\>\\s\\(\\)]*[\\:\\>])?\n"
+ " (?P<pattern>\n"
+ " (?:[^\\)\\(]*(?R)*)*\n"
+ " )\n"
+ " \\)\n"
+ " (?P<quantifier>\n"
+ " (?:[\\*\\+\\?])|\n"
+ " (?:\n"
+ " \\{(?P<min>\\d*)\n"
+ " (?:\n"
+ " ,\n"
+ " (?P<max>\\d*)?\n"
+ " )?\n"
+ " \\}\n"
+ " )\n"
+ " )?\n"
+ ")";
final String string = "^(?P<line>(?P<junk>(?!(?:Message\\-ID:)\\s(?:\\<)|(?:<)|(?:\\s))(?!(?:From:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:To:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Reply\\-To:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:X\\-Sender:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Return\\-Path:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Received\\-SPF:))[^\\r\\n]*)(?P<wtf>(?:(?:\\\"(?P<display_name>[^\\\"\\r\\n]*)\\\"\\s*)?\\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\\.)*)?(?P<sld>[A-Z0-9.-]+)\\.(?P<tld>[A-Z]{2,4})))\\b)\\h*)(?P<trailing_data>[^\\r\\n]*))$\n\n"
+ "(this is a group)?\n\n"
+ "(another group (with a group inside)) and soem bogus test (and then another group)\n\n\n"
+ "(?P<group_definition>\n"
+ " (?P<pattern>\n"
+ " \\(\n"
+ " (?:[^\\)\\(]*(?R)*)*\n"
+ " \\)\n"
+ " )\n"
+ " (?P<quantifier>\n"
+ " (?:[\\*\\+\\?])|\n"
+ " (?:\n"
+ " \\{(?P<min>\\d*)\n"
+ " (?:\n"
+ " ,\n"
+ " (?P<max>\\d*)?\n"
+ " )?\n"
+ " \\}\n"
+ " )\n"
+ " )?\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}