# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?P<group_definition>
\(
(?P<options>[^\:\>\s\(\)]*[\:\>])?
(?P<pattern>
(?:[^\)\(]*(?R)*)*
)
\)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)
"""
test_str = ("^(?P<line>(?P<junk>(?!(?:Message\\-ID:)\\s(?:\\<)|(?:<)|(?:\\s))(?!(?:From:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:To:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Reply\\-To:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:X\\-Sender:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Return\\-Path:)\\s(?:\\<)|(?:<)|(?:")|(?:[\"]))(?!(?:Received\\-SPF:))[^\\r\\n]*)(?P<wtf>(?:(?:\\\"(?P<display_name>[^\\\"\\r\\n]*)\\\"\\s*)?\\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\\.)*)?(?P<sld>[A-Z0-9.-]+)\\.(?P<tld>[A-Z]{2,4})))\\b)\\h*)(?P<trailing_data>[^\\r\\n]*))$\n\n"
"(this is a group)?\n\n"
"(another group (with a group inside)) and soem bogus test (and then another group)\n\n\n"
"(?P<group_definition>\n"
" (?P<pattern>\n"
" \\(\n"
" (?:[^\\)\\(]*(?R)*)*\n"
" \\)\n"
" )\n"
" (?P<quantifier>\n"
" (?:[\\*\\+\\?])|\n"
" (?:\n"
" \\{(?P<min>\\d*)\n"
" (?:\n"
" ,\n"
" (?P<max>\\d*)?\n"
" )?\n"
" \\}\n"
" )\n"
" )?\n"
")")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.