import Foundation
let pattern = #"""
(?P<group_definition>
\(
(?P<options>[^\:\>\s\(\)]*[\:\>])?
(?P<pattern>
(?:[^\)\(]*(?R)*)*
)
\)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
^(?P<line>(?P<junk>(?!(?:Message\-ID:)\s(?:\<)|(?:<)|(?:\s))(?!(?:From:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:To:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Reply\-To:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:X\-Sender:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Return\-Path:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Received\-SPF:))[^\r\n]*)(?P<wtf>(?:(?:\"(?P<display_name>[^\"\r\n]*)\"\s*)?\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\.)*)?(?P<sld>[A-Z0-9.-]+)\.(?P<tld>[A-Z]{2,4})))\b)\h*)(?P<trailing_data>[^\r\n]*))$
(this is a group)?
(another group (with a group inside)) and soem bogus test (and then another group)
(?P<group_definition>
(?P<pattern>
\(
(?:[^\)\(]*(?R)*)*
\)
)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)