package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?P<group_definition>
\(
(?P<options>[^\:\>\s\(\)]*[\:\>])?
(?P<pattern>
(?:[^\)\(]*(?R)*)*
)
\)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)`)
var str = `^(?P<line>(?P<junk>(?!(?:Message\-ID:)\s(?:\<)|(?:<)|(?:\s))(?!(?:From:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:To:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Reply\-To:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:X\-Sender:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Return\-Path:)\s(?:\<)|(?:<)|(?:")|(?:["]))(?!(?:Received\-SPF:))[^\r\n]*)(?P<wtf>(?:(?:\"(?P<display_name>[^\"\r\n]*)\"\s*)?\b(?P<email>(?P<username>[A-Z0-9._%-]+)@(?P<domain_name>(?P<host>(?:[A-Z0-9.-]+\.)*)?(?P<sld>[A-Z0-9.-]+)\.(?P<tld>[A-Z]{2,4})))\b)\h*)(?P<trailing_data>[^\r\n]*))$
(this is a group)?
(another group (with a group inside)) and soem bogus test (and then another group)
(?P<group_definition>
(?P<pattern>
\(
(?:[^\)\(]*(?R)*)*
\)
)
(?P<quantifier>
(?:[\*\+\?])|
(?:
\{(?P<min>\d*)
(?:
,
(?P<max>\d*)?
)?
\}
)
)?
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}