#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$"
Local $sString = "ERT-WERT123" & @CRLF & _
"WRF1234" & @CRLF & _
"ERWERWERW#;';" & @CRLF & _
"EREG$%UY^657" & @CRLF & _
""Any character" + "-" + "Any character" + "a number" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)" & @CRLF & _
"or "Any character" + "a number" // ^([a-zA-Z]+[0-9]+)" & @CRLF & _
"or "Any character" (without any number at the end)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")