use strict;
my $str = 'ERT-WERT123
WRF1234
ERWERWERW#;\';
EREG$%UY^657
"Any character" + "-" + "Any character" + "a number" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)
or "Any character" + "a number" // ^([a-zA-Z]+[0-9]+)
or "Any character" (without any number at the end)';
my $regex = qr/^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}