const regex = /^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$', 'gm')
const str = `ERT-WERT123
WRF1234
ERWERWERW#;';
EREG\$%UY^657
"Any character" + "-" + "Any character" + "a number" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)
or "Any character" + "a number" // ^([a-zA-Z]+[0-9]+)
or "Any character" (without any number at the end)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}