$re = '/^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$/m';
$str = 'ERT-WERT123
WRF1234
ERWERWERW#;\';
EREG$%UY^657
"Any character" + "-" + "Any character" + "a number" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)
or "Any character" + "a number" // ^([a-zA-Z]+[0-9]+)
or "Any character" (without any number at the end)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);