import Foundation
let pattern = #"^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ERT-WERT123
WRF1234
ERWERWERW#;';
EREG$%UY^657
"Any character" + "-" + "Any character" + "a number" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)
or "Any character" + "a number" // ^([a-zA-Z]+[0-9]+)
or "Any character" (without any number at the end)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)