using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]+(?:(?:-[a-zA-Z]+)?[0-9]+|(?!.*[0-9]$).*)$";
string input = @"ERT-WERT123
WRF1234
ERWERWERW#;';
EREG$%UY^657
""Any character"" + ""-"" + ""Any character"" + ""a number"" // ^([a-zA-Z]+)-([a-zA-Z]+[0-9]+)
or ""Any character"" + ""a number"" // ^([a-zA-Z]+[0-9]+)
or ""Any character"" (without any number at the end)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}