using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*([os])(?:.*\1){1})(?!.*([p])(?:.*\2){2})[pos]+$";
string input = @"pop
sop
ps
pops
poop
p
pp
ppp
pppp
o
oo
s
ss
popp
ppos";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}