import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([os])(?:.*\\1){1})(?!.*([p])(?:.*\\2){2})[pos]+$";
final String string = "pop\n"
+ "sop\n"
+ "ps\n"
+ "pops\n"
+ "poop\n"
+ "p\n"
+ "pp\n"
+ "ppp\n"
+ "pppp\n"
+ "o\n"
+ "oo\n"
+ "s\n"
+ "ss\n"
+ "popp\n"
+ "ppos";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}