const regex = /^(?!.*([os])(?:.*\1){1})(?!.*([p])(?:.*\2){2})[pos]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*([os])(?:.*\\1){1})(?!.*([p])(?:.*\\2){2})[pos]+$', 'gm')
const str = `pop
sop
ps
pops
poop
p
pp
ppp
pppp
o
oo
s
ss
popp
ppos`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}