$re = '/^(?!.*([os])(?:.*\1){1})(?!.*([p])(?:.*\2){2})[pos]+$/m';
$str = 'pop
sop
ps
pops
poop
p
pp
ppp
pppp
o
oo
s
ss
popp
ppos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);