using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((-.*?)\)";
string input = @"2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}