import Foundation
let pattern = #"\((-.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}