re = /\((-.*?)\)/
str = '2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code'
# Print the match result
str.match(re) do |match|
puts match.to_s
end