const regex = /\((-.*?)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((-.*?)\\)', '')
const str = `2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}