package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((-.*?)\)`)
var str = `2016/99/99 12:00:0.999 2 1 (-499) Cannot open the message store with error code`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}