#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\-(?=\S)"
Local $sString = "car \- https://youtu.be/iOA7NUI\-9Xhw video\-one \-"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)