$re = '/\\\\-(?=\S)/';
$str = 'car \\- https://youtu.be/iOA7NUI\\-9Xhw video\\-one \\-';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;