use strict;
my $str = 'car \\- https://youtu.be/iOA7NUI\\-9Xhw video\\-one \\-';
my $regex = qr/\\-(?=\S)/p;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";