using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\-(?=\S)";
string substitution = @"-";
string input = @"car \- https://youtu.be/iOA7NUI\-9Xhw video\-one \-";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}