re = /\\-(?=\S)/
str = 'car \\- https://youtu.be/iOA7NUI\\-9Xhw video\\-one \\-'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result