# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^_]*_([^_]*).*/\1/gm;t' <<< "Arof_07122016_2.csv"