$re = '/^[^_]*_([^_]*).*/m';
$str = 'Arof_07122016_2.csv';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;