use strict;
my $str = 'Arof_07122016_2.csv';
my $regex = qr/^[^_]*_([^_]*).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";