const regex = /^[^_]*_([^_]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^_]*_([^_]*).*', 'gm')
const str = `Arof_07122016_2.csv`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);