import re
regex = re.compile(r"^[^_]*_([^_]*).*", flags=re.MULTILINE)
test_str = "Arof_07122016_2.csv"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)