#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![.\d])(?<number>\d*(?:\.\d+)?)\s*\)"
Local $sString = "cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)" & @CRLF & _
"cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)" & @CRLF & _
"" & @CRLF & _
"(3 *(2+1+1) - 23/5)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")