const regex = /(?<![.\d])(?<number>\d*(?:\.\d+)?)\s*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![.\\d])(?<number>\\d*(?:\\.\\d+)?)\\s*\\)', 'g')
const str = `cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)
(3 *(2+1+1) - 23/5)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}