using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![.\d])(?<number>\d*(?:\.\d+)?)\s*\)";
string input = @"cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)
(3 *(2+1+1) - 23/5)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}