re = /(?<![.\d])(?<number>\d*(?:\.\d+)?)\s*\)/
str = 'cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)
(3 *(2+1+1) - 23/5)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end