use strict;
my $str = 'cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)
cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)
(3 *(2+1+1) - 23/5)';
my $regex = qr/(?<![.\d])(?<number>\d*(?:\.\d+)?)\s*\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}