import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![.\\d])(?<number>\\d*(?:\\.\\d+)?)\\s*\\)";
final String string = "cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * 2.4)\n"
+ "cos(3 * 3.4) + cos(3 * 45 ), cos(4 * 2 ) + cos(3 * 245)\n\n"
+ "(3 *(2+1+1) - 23/5)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}