#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<number>(?<!\.)\d+(?:\.\d+)?|(?<![\d.])(?:\.\d+)(?!\.))(?<termination>\s*[-+)])"
Local $sString = "cos(3 * 3) + cos(3 * 24.5 ), cos(2 * 3 ) + cos(3 * .2.4)" & @CRLF & _
"cos(3 * 3.4) + cos(3 * 45 ), cos(4 * .24) + cos(3 * 245 )" & @CRLF & _
"" & @CRLF & _
"(3 *(2 + 1 + 1) - 23/5 )" & @CRLF & _
"" & @CRLF & _
"3 * (1571 - sin(12))"
Local $sSubst = "$1deg$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)